Back to overview
Resolved

Sales app currently under heavy load

Aug 19, 2026 at 3:34pm UTC
Affected services
Login page
Authentication requests
Conversations page
Contacts page

Resolved
Aug 19, 2026 at 3:44pm UTC

The sales app is back to normal.

Created
Aug 19, 2026 at 3:34pm UTC

The sales app might present some instability while interacting with it. Our team is investigating the issue